summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvojo <joris.van.vossen@sintecs.nl>2017-06-26 13:48:28 (GMT)
committervojo <joris.van.vossen@sintecs.nl>2017-06-26 13:51:36 (GMT)
commit485f99be969f973050567cdd5283befa92022d97 (patch)
tree89ebc48ce44ce6780de2843a0f7a8ac5f6a8c09d
parentb445b2005332bcbcbcb345f47d2d9a263dfbcf6d (diff)
downloadmeta-scalys-ppc-485f99be969f973050567cdd5283befa92022d97.tar.xz
Support for the NXP SDK v2.0 with patch 1703
-rw-r--r--conf/layer.conf2
-rw-r--r--conf/machine/QT1040-1GB.conf35
-rw-r--r--conf/machine/simc-t1022-tcb-02.conf2
-rw-r--r--conf/machine/simc-t1040-tcb-02.conf37
-rw-r--r--conf/machine/simc-t2081-tcb-02.conf37
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2015.01.bbappend2
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.09.bbappend2
-rw-r--r--recipes-kernel/linux/files/fit_image_template.its2
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bbappend (renamed from recipes-kernel/linux/linux-qoriq_3.12.bbappend)7
9 files changed, 118 insertions, 8 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index f65cbe4..65d2d03 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "scalys-ppc"
BBFILE_PATTERN_scalys-ppc := "^${LAYERDIR}/"
-BBFILE_PRIORITY_scalys-ppc = "4"
+BBFILE_PRIORITY_scalys-ppc = "6"
diff --git a/conf/machine/QT1040-1GB.conf b/conf/machine/QT1040-1GB.conf
new file mode 100644
index 0000000..71e82c5
--- /dev/null
+++ b/conf/machine/QT1040-1GB.conf
@@ -0,0 +1,35 @@
+#@TYPE: Machine
+#@NAME: Scalys simc-t1040 Module on a TCB-02 carrier board
+#@SOC: t1040
+#@DESCRIPTION: Machine configuration for Sintecs simc-t1040 module on a TCB-02
+#@MAINTAINER: Evert Pap <evert.pap@sintecs.nl>
+
+require conf/machine/include/e5500-64b.inc
+
+SOC_FAMILY = "t1:t1040"
+
+PREFERRED_PROVIDER_virtual/bootloader = "${PREFERRED_PROVIDER_u-boot}"
+UBOOT_CONFIG ??= "nand"
+UBOOT_CONFIG[nand] = "QT1040-1GB_nand_config"
+
+KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/simc-t10xx_defconfig"
+KERNEL_DEVICETREE ?= "fsl/simc-t1040.dtb"
+KERNEL_FIT_IMAGES ?= "simc-t1040"
+
+# Images types generated for this machine
+IMAGE_FSTYPES = "tar.bz2 ubifs ubi"
+
+# mkfs.ubi options:
+# Find parameter values on target with `ubinfo -a`
+# -m, --min-io-size=SIZE minimum I/O unit size
+# -e, --leb-size=SIZE logical erase block size
+# -c, --max-leb-cnt=COUNT maximum logical erase block count
+MKUBIFS_ARGS = "--space-fixup -m 2048 -e 124KiB -c 10000"
+
+# ubinize options:
+# Find parameter values on target with `mtdinfo -a`
+# -p, --peb-size=<bytes> size of the physical eraseblock of the flash
+# -m, --min-io-size=<bytes> minimum input/output unit size of the flash in bytes
+# -s, --sub-page-size=<bytes> minimum input/output unit used for UBI headers
+UBINIZE_ARGS = "-m 2048 -p 128KiB -s 2048"
+UBI_VOLNAME = "rootfs"
diff --git a/conf/machine/simc-t1022-tcb-02.conf b/conf/machine/simc-t1022-tcb-02.conf
index 0239999..b83b436 100644
--- a/conf/machine/simc-t1022-tcb-02.conf
+++ b/conf/machine/simc-t1022-tcb-02.conf
@@ -9,7 +9,7 @@ require conf/machine/include/e5500-64b.inc
SOC_FAMILY = "t1:t1022"
KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/simc-t10xx_defconfig"
-KERNEL_DEVICETREE ?= "simc-t1022.dtb"
+KERNEL_DEVICETREE ?= "fsl/simc-t1022.dtb"
KERNEL_FIT_IMAGES ?= "simc-t1022"
PREFERRED_PROVIDER_virtual/bootloader = "${PREFERRED_PROVIDER_u-boot}"
diff --git a/conf/machine/simc-t1040-tcb-02.conf b/conf/machine/simc-t1040-tcb-02.conf
new file mode 100644
index 0000000..9db2969
--- /dev/null
+++ b/conf/machine/simc-t1040-tcb-02.conf
@@ -0,0 +1,37 @@
+#@TYPE: Machine
+#@NAME: Scalys simc-t1040 Module on a TCB-02 carrier board
+#@SOC: t1040
+#@DESCRIPTION: Machine configuration for Sintecs simc-t1040 module on a TCB-02
+#@MAINTAINER: Evert Pap <evert.pap@sintecs.nl>
+
+require conf/machine/include/e5500-64b.inc
+
+SOC_FAMILY = "t1:t1040"
+
+KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/simc-t10xx_defconfig"
+KERNEL_DEVICETREE ?= "fsl/simc-t1040.dtb"
+KERNEL_FIT_IMAGES ?= "simc-t1040"
+
+PREFERRED_PROVIDER_virtual/bootloader = "${PREFERRED_PROVIDER_u-boot}"
+UBOOT_CONFIG ??= "nand"
+UBOOT_CONFIG[nand] = "T1_simc-t10xx_nand_config"
+
+# Images types generated for this machine
+IMAGE_FSTYPES = "tar.bz2 ubifs ubi"
+
+# mkfs.ubi options:
+# Find parameter values on target with `ubinfo -a`
+# -m, --min-io-size=SIZE minimum I/O unit size
+# -e, --leb-size=SIZE logical erase block size
+# -c, --max-leb-cnt=COUNT maximum logical erase block count
+MKUBIFS_ARGS = "--space-fixup -m 2048 -e 124KiB -c 10000"
+
+# ubinize options:
+# Find parameter values on target with `mtdinfo -a`
+# -p, --peb-size=<bytes> size of the physical eraseblock of the flash
+# -m, --min-io-size=<bytes> minimum input/output unit size of the flash in bytes
+# -s, --sub-page-size=<bytes> minimum input/output unit used for UBI headers
+UBINIZE_ARGS = "-m 2048 -p 128KiB -s 2048"
+UBI_VOLNAME = "rootfs"
+
+
diff --git a/conf/machine/simc-t2081-tcb-02.conf b/conf/machine/simc-t2081-tcb-02.conf
new file mode 100644
index 0000000..152c4e5
--- /dev/null
+++ b/conf/machine/simc-t2081-tcb-02.conf
@@ -0,0 +1,37 @@
+#@TYPE: Machine
+#@NAME: Scalys simc-t2081 Module on a TCB-02 carrier board
+#@SOC: t2081
+#@DESCRIPTION: Machine configuration for Sintecs simc-t2081 module on a TCB-02
+#@MAINTAINER: Evert Pap <evert.pap@sintecs.nl>
+
+require conf/machine/include/e6500-64b.inc
+
+SOC_FAMILY = "t2:t2081"
+
+KERNEL_DEFCONFIG ?= "TODO-t2081_defconfig"
+KERNEL_DEVICETREE ?= "TODO-t2081.dtb"
+KERNEL_FIT_IMAGES ?= "TODO-t2081"
+
+PREFERRED_PROVIDER_virtual/bootloader = "${PREFERRED_PROVIDER_u-boot}"
+UBOOT_CONFIG ??= "nand"
+UBOOT_CONFIG[nand] = "T1_simc-t2081_nand_config"
+
+# Images types generated for this machine
+IMAGE_FSTYPES = "tar.bz2 ubifs ubi"
+
+# mkfs.ubi options:
+# Find parameter values on target with `ubinfo -a`
+# -m, --min-io-size=SIZE minimum I/O unit size
+# -e, --leb-size=SIZE logical erase block size
+# -c, --max-leb-cnt=COUNT maximum logical erase block count
+MKUBIFS_ARGS = "--space-fixup -m 2048 -e 124KiB -c 10000"
+
+# ubinize options:
+# Find parameter values on target with `mtdinfo -a`
+# -p, --peb-size=<bytes> size of the physical eraseblock of the flash
+# -m, --min-io-size=<bytes> minimum input/output unit size of the flash in bytes
+# -s, --sub-page-size=<bytes> minimum input/output unit used for UBI headers
+UBINIZE_ARGS = "-m 2048 -p 128KiB -s 2048"
+UBI_VOLNAME = "rootfs"
+
+
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bbappend b/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bbappend
deleted file mode 100644
index 875859e..0000000
--- a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-SRC_URI = "git://git.scalys.com/u-boot-fsl-qoriq;branch=scalys"
-SRCREV = "96602f16d3abad2d2871ec2d09194789c540fa47"
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bbappend b/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bbappend
new file mode 100644
index 0000000..07ae517
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bbappend
@@ -0,0 +1,2 @@
+SRC_URI = "git://source.sintecs.nl/scalys/u-boot-fsl-qoriq;protocol=http;branch=scalys"
+SRCREV = "5d4f955da4df52fab89438bce8b3836d3450b9e5"
diff --git a/recipes-kernel/linux/files/fit_image_template.its b/recipes-kernel/linux/files/fit_image_template.its
index 29f544b..9eb4722 100644
--- a/recipes-kernel/linux/files/fit_image_template.its
+++ b/recipes-kernel/linux/files/fit_image_template.its
@@ -27,7 +27,7 @@
};
fdt@1 {
description = "Flattened Device Tree blob";
- data = /incbin/("./arch/powerpc/boot/DTB_PLACEHOLDER.dtb");
+ data = /incbin/("./arch/powerpc/boot/fsl/DTB_PLACEHOLDER.dtb");
type = "flat_dt";
arch = "ppc";
compression = "none";
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bbappend b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
index b972e24..fb42674 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
@@ -1,10 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRCREV = "615c21a0bb56fc8af6e936dc7c2dd78d9eb52a60"
SRC_URI = "\
- git://git.scalys.com/linux-fsl-qoriq;branch=scalys \
+ git://source.sintecs.nl/scalys/linux-fsl-qoriq;protocol=http;branch=scalys \
file://fit_image_template.its \
"
-SRCREV = "0247864d78189c1ca73dfba348eeddcfeb618a35"
+
python __anonymous () {
d.appendVar("PACKAGES", " kernel-fitimage")
@@ -43,4 +44,4 @@ do_kernel_fitimage() {
}
# The install stage generates the DTB needed for the FIT image (linux-dtb.inc)
-addtask do_kernel_fitimage after do_install before do_deploy \ No newline at end of file
+addtask do_kernel_fitimage after do_install before do_deploy