summaryrefslogtreecommitdiff
path: root/recipes-benchmark/stress-ng/stress-ng_0.08.06.bb
diff options
context:
space:
mode:
authorvojo <joris.van.vossen@sintecs.nl>2017-09-15 13:41:52 (GMT)
committervojo <joris.van.vossen@sintecs.nl>2017-09-15 13:41:52 (GMT)
commit62fa475fdeb422181b3ccda29cd74629649a27cd (patch)
tree2f5cbac6cffcf759d9672debb16769479d6d906c /recipes-benchmark/stress-ng/stress-ng_0.08.06.bb
parente64e0e91fb521c6248f2cdebd98ee273c6f728d0 (diff)
downloadmeta-scalys-ppc-62fa475fdeb422181b3ccda29cd74629649a27cd.tar.xz
added simc-t2081 machine support and virtualization image
Diffstat (limited to 'recipes-benchmark/stress-ng/stress-ng_0.08.06.bb')
-rwxr-xr-xrecipes-benchmark/stress-ng/stress-ng_0.08.06.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-benchmark/stress-ng/stress-ng_0.08.06.bb b/recipes-benchmark/stress-ng/stress-ng_0.08.06.bb
new file mode 100755
index 0000000..ae906be
--- /dev/null
+++ b/recipes-benchmark/stress-ng/stress-ng_0.08.06.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "stress-ng will stress test a computer system in various selectable ways. \
+ It was designed to exercise various physical subsystems of a computer as well as the \
+ various operating system kernel interfaces."
+HOMEPAGE = "http://kernel.ubuntu.com/~cking/stress-ng/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://kernel.ubuntu.com/cking/stress-ng.git;protocol=git"
+SRCREV = "8a91f84659a66fb7aa85db032bee49445449f1e7"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake CFLAGS="-DVERSION=\\\"${PV}\\\""
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} BINDIR=${bindir} MANDIR=${mandir}
+ chown -R root:root ${D} ${bindir} ${mandir}
+}