summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorvojo <joris.van.vossen@sintecs.nl>2017-06-26 13:48:28 (GMT)
committervojo <joris.van.vossen@sintecs.nl>2017-06-26 13:51:36 (GMT)
commit485f99be969f973050567cdd5283befa92022d97 (patch)
tree89ebc48ce44ce6780de2843a0f7a8ac5f6a8c09d /recipes-kernel
parentb445b2005332bcbcbcb345f47d2d9a263dfbcf6d (diff)
downloadmeta-scalys-ppc-485f99be969f973050567cdd5283befa92022d97.tar.xz
Support for the NXP SDK v2.0 with patch 1703
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/files/fit_image_template.its2
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bbappend (renamed from recipes-kernel/linux/linux-qoriq_3.12.bbappend)7
2 files changed, 5 insertions, 4 deletions
diff --git a/recipes-kernel/linux/files/fit_image_template.its b/recipes-kernel/linux/files/fit_image_template.its
index 29f544b..9eb4722 100644
--- a/recipes-kernel/linux/files/fit_image_template.its
+++ b/recipes-kernel/linux/files/fit_image_template.its
@@ -27,7 +27,7 @@
};
fdt@1 {
description = "Flattened Device Tree blob";
- data = /incbin/("./arch/powerpc/boot/DTB_PLACEHOLDER.dtb");
+ data = /incbin/("./arch/powerpc/boot/fsl/DTB_PLACEHOLDER.dtb");
type = "flat_dt";
arch = "ppc";
compression = "none";
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bbappend b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
index b972e24..fb42674 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
@@ -1,10 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRCREV = "615c21a0bb56fc8af6e936dc7c2dd78d9eb52a60"
SRC_URI = "\
- git://git.scalys.com/linux-fsl-qoriq;branch=scalys \
+ git://source.sintecs.nl/scalys/linux-fsl-qoriq;protocol=http;branch=scalys \
file://fit_image_template.its \
"
-SRCREV = "0247864d78189c1ca73dfba348eeddcfeb618a35"
+
python __anonymous () {
d.appendVar("PACKAGES", " kernel-fitimage")
@@ -43,4 +44,4 @@ do_kernel_fitimage() {
}
# The install stage generates the DTB needed for the FIT image (linux-dtb.inc)
-addtask do_kernel_fitimage after do_install before do_deploy \ No newline at end of file
+addtask do_kernel_fitimage after do_install before do_deploy