summaryrefslogtreecommitdiff
path: root/recipes-benchmark/stress-ng/stress-ng_0.04.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-benchmark/stress-ng/stress-ng_0.04.07.bb')
-rwxr-xr-xrecipes-benchmark/stress-ng/stress-ng_0.04.07.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-benchmark/stress-ng/stress-ng_0.04.07.bb b/recipes-benchmark/stress-ng/stress-ng_0.04.07.bb
new file mode 100755
index 0000000..40b84b6
--- /dev/null
+++ b/recipes-benchmark/stress-ng/stress-ng_0.04.07.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "stress-ng will stress test a computer system in various selectable ways. \
+ It was designed to exercise various physical subsystems of a computer as well as the \
+ various operating system kernel interfaces."
+HOMEPAGE = "http://kernel.ubuntu.com/~cking/stress-ng/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://kernel.ubuntu.com/cking/stress-ng.git;protocol=git"
+SRCREV = "6e57b577400791b100d07421834fb33d7941f7ab"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake CFLAGS="-DVERSION=\\\"${PV}\\\""
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} BINDIR=${bindir} MANDIR=${mandir}
+}