summaryrefslogtreecommitdiff
path: root/recipes-benchmark/stress-ng/stress-ng_0.08.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-benchmark/stress-ng/stress-ng_0.08.15.bb')
-rw-r--r--recipes-benchmark/stress-ng/stress-ng_0.08.15.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-benchmark/stress-ng/stress-ng_0.08.15.bb b/recipes-benchmark/stress-ng/stress-ng_0.08.15.bb
new file mode 100644
index 0000000..7397b2a
--- /dev/null
+++ b/recipes-benchmark/stress-ng/stress-ng_0.08.15.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "stress-ng will stress test a computer system in various selectable ways. \
+ It was designed to exercise various physical subsystems of a computer as well as the \
+ various operating system kernel interfaces."
+HOMEPAGE = "http://kernel.ubuntu.com/~cking/stress-ng/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://kernel.ubuntu.com/cking/stress-ng.git;protocol=git"
+SRCREV = "e59ea5d3c246361880f096d25ac6361dd4590f81"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "\
+ 'CC=${CC}' \
+ 'CFLAGS=${CFLAGS}' \
+ 'LFLAGS=${LDFLAGS} -lrt' \
+"
+
+do_compile() {
+ oe_runmake CFLAGS="-DVERSION=\\\"${PV}\\\""
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} BINDIR=${bindir} MANDIR=${mandir}
+ chown -R root:root ${D} ${bindir} ${mandir}
+} \ No newline at end of file