summaryrefslogtreecommitdiff
path: root/recipes-devtools/memtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/memtool/Makefile')
-rwxr-xr-xrecipes-devtools/memtool/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/memtool/Makefile b/recipes-devtools/memtool/Makefile
new file mode 100755
index 0000000..00fbc35
--- /dev/null
+++ b/recipes-devtools/memtool/Makefile
@@ -0,0 +1,26 @@
+# Assuming that you have CROSS_COMPILE defined iff you are not building under Yocto
+ifdef CROSS_COMPILE
+CC = $(CROSS_COMPILE)gcc
+endif
+
+CFLAGS = -O0 -fno-omit-frame-pointer
+
+all:
+ $(CC) $(CFLAGS) memtool.c -pthread -o memtool
+ @file memtool
+
+.PHONY : help
+help:
+ @echo "usage of this Makefile"
+ @echo "make : builds the application (same as 'make all')"
+ @echo "make clean : clean binaries"
+ @echo "make release : makes a tar ball of these sources"
+ @echo "make help : this message"
+
+.PHONY : clean
+clean:
+ -rm -rf memtool *.o memtool.tar.gz
+
+.PHONY : release
+release: clean
+ tar czf memtool.tar.gz *.c Makefile