summaryrefslogtreecommitdiff
path: root/recipes-devtools/memtool/memtool_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/memtool/memtool_1.0.bb')
-rwxr-xr-xrecipes-devtools/memtool/memtool_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-devtools/memtool/memtool_1.0.bb b/recipes-devtools/memtool/memtool_1.0.bb
new file mode 100755
index 0000000..152dc55
--- /dev/null
+++ b/recipes-devtools/memtool/memtool_1.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "tools to inspect or alter memory"
+SECTION = "dev tools"
+LICENSE = "GPLv2"
+
+PV = "1.0"
+PR = "r0"
+
+SRC_URI = "file://memtool.c file://Makefile"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 memtool ${D}${bindir}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+
+FILESPATH = "${FILE_DIRNAME}"
+FILES_${PN} = "${bindir}/memtool"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT_${PN} = "1"
+INSANE_SKIP_${PN} += "ldflags"
+