summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-qoriq_4.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.1.bbappend')
-rwxr-xr-x[-rw-r--r--]recipes-kernel/linux/linux-qoriq_4.1.bbappend18
1 files changed, 13 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bbappend b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
index 102703e..8659cb2 100644..100755
--- a/recipes-kernel/linux/linux-qoriq_4.1.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
@@ -1,7 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRCREV = "df40dca3df785ec7f1cc7eb04812ab207499d65e"
-SRC_URI = "git://source.sintecs.nl/scalys/linux-fsl-qoriq;protocol=http;branch=scalys file://fit_image_template.its"
+#SRC_URI main is in meta-freescale/src-nxp-npi-1703 layers
+SRC_URI += "file://simc-t10xx_device_tree_addition.patch file://fit_image_template.its"
+SRC_URI += "file://simc-t2081_device_tree_addition.patch"
python __anonymous () {
d.appendVar("PACKAGES", " kernel-fitimage")
@@ -9,9 +10,16 @@ python __anonymous () {
FILES_kernel-fitimage = "/boot/"
-# Appending of simc-t10xx specific kernel configs to the used defconfig.
+# Appending of simc-txxxx specific kernel configs to the used defconfig.
do_configure_prepend() {
- cat ${THISDIR}/../../../meta-scalys-ppc/recipes-kernel/linux/files/defconfig_append_t10xx >> ${KERNEL_DEFCONFIG}
+ if [ "${MACHINE}" = "simc-t2081-tcb-02" ] ; then
+ cat ${THISDIR}/../../../meta-scalys-ppc/recipes-kernel/linux/files/defconfig_append_simc-t2081 >> ${KERNEL_DEFCONFIG}
+ else
+ cat ${THISDIR}/../../../meta-scalys-ppc/recipes-kernel/linux/files/defconfig_append_simc-t10xx >> ${KERNEL_DEFCONFIG}
+ fi
+
+ # uncomment next line to insert virt kernel configs
+ #cat ${THISDIR}/../../../meta-scalys-ppc/recipes-kernel/linux/files/defconfig_append_simc-txxxx-virt >> ${KERNEL_DEFCONFIG}
}
do_kernel_fitimage() {
@@ -23,7 +31,7 @@ do_kernel_fitimage() {
# Assemble the name for the fitImage
ITB_NAME=`echo ${KERNEL_IMAGE_BASE_NAME} | sed "s/${MACHINE}/${i}/g" | sed "s/uImage-/fitImage/g"`
- ITB_SYMLINK_NAME=`echo ${KERNEL_IMAGE_SYMLINK_NAME} | sed "s/${MACHINE}/${i}/g"`
+ #ITB_SYMLINK_NAME=`echo ${KERNEL_IMAGE_SYMLINK_NAME} | sed "s/${MACHINE}/${i}/g"`
install -d ${DEPLOYDIR}
install -m 0644 ${B}/arch/${ARCH}/boot/${i}.itb ${DEPLOYDIR}/${ITB_NAME}.itb