summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-qoriq_4.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.1.bbappend')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bbappend15
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bbappend b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
index fb42674..102703e 100644
--- a/recipes-kernel/linux/linux-qoriq_4.1.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
@@ -1,11 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRCREV = "615c21a0bb56fc8af6e936dc7c2dd78d9eb52a60"
-SRC_URI = "\
- git://source.sintecs.nl/scalys/linux-fsl-qoriq;protocol=http;branch=scalys \
- file://fit_image_template.its \
-"
-
+SRCREV = "df40dca3df785ec7f1cc7eb04812ab207499d65e"
+SRC_URI = "git://source.sintecs.nl/scalys/linux-fsl-qoriq;protocol=http;branch=scalys file://fit_image_template.its"
python __anonymous () {
d.appendVar("PACKAGES", " kernel-fitimage")
@@ -13,6 +9,11 @@ python __anonymous () {
FILES_kernel-fitimage = "/boot/"
+# Appending of simc-t10xx specific kernel configs to the used defconfig.
+do_configure_prepend() {
+ cat ${THISDIR}/../../../meta-scalys-ppc/recipes-kernel/linux/files/defconfig_append_t10xx >> ${KERNEL_DEFCONFIG}
+}
+
do_kernel_fitimage() {
cd ${B}
for i in ${KERNEL_FIT_IMAGES}; do
@@ -44,4 +45,4 @@ do_kernel_fitimage() {
}
# The install stage generates the DTB needed for the FIT image (linux-dtb.inc)
-addtask do_kernel_fitimage after do_install before do_deploy
+addtask do_kernel_fitimage after do_install before do_package