summaryrefslogtreecommitdiff
path: root/recipes-support/cluster-glue/cluster-glue_1.0.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/cluster-glue/cluster-glue_1.0.12.bb')
-rwxr-xr-xrecipes-support/cluster-glue/cluster-glue_1.0.12.bb129
1 files changed, 129 insertions, 0 deletions
diff --git a/recipes-support/cluster-glue/cluster-glue_1.0.12.bb b/recipes-support/cluster-glue/cluster-glue_1.0.12.bb
new file mode 100755
index 0000000..5513ed8
--- /dev/null
+++ b/recipes-support/cluster-glue/cluster-glue_1.0.12.bb
@@ -0,0 +1,129 @@
+DESCRIPTION = "Cluster Glue is a set of libraries, tools and utilities suitable for \
+the Heartbeat/Pacemaker cluster stack. In essence, Glue is everything that \
+is not the cluster messaging layer (Heartbeat), nor the cluster resource manager \
+(Pacemaker), nor a Resource Agent."
+
+LICENSE = "GPLv2"
+DEPENDS = "libxml2 libtool glib-2.0 bzip2 util-linux net-snmp"
+
+SRC_URI = " \
+ http://hg.linux-ha.org/glue/archive/glue-${PV}.tar.bz2 \
+ file://0001-remove-doc-generation.patch \
+ file://volatiles \
+ file://tmpfiles \
+ "
+SRC_URI_append_libc-uclibc = " file://kill-stack-protector.patch"
+SRC_URI[md5sum] = "ec620466d6f23affa3b074b72bca7870"
+SRC_URI[sha256sum] = "feba102fa1e24b6be2005089ebe362b82d6567af60005cf371679b1b44ec503f"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.GPLv2;md5=751419260aa954499f7abaabaa882bbe"
+
+inherit autotools-brokensep useradd
+
+S = "${WORKDIR}/Reusable-Cluster-Components-glue--glue-${PV}"
+#B = "${S}"
+
+EXTRA_OECONF = "--with-daemon-user=hacluster --with-daemon-group=haclient --disable-fatal-warnings --disable-upstart"
+
+CACHED_CONFIGUREVARS="ac_cv_path_XML2CONFIG=0"
+
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--home-dir=${localstatedir}/lib/heartbeat -g haclient -r hacluster"
+GROUPADD_PARAM_${PN} = "-r haclient"
+
+do_configure_prepend() {
+ ln -sf ${PKG_CONFIG_SYSROOT_DIR}/usr/include/libxml2/libxml ${PKG_CONFIG_SYSROOT_DIR}/usr/include/libxml
+}
+
+do_configure() {
+ ./autogen.sh
+ oe_runconf
+}
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/default/volatiles
+ install -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/04_cluster-glue
+ install -d ${D}${sysconfdir}/tmpfiles.d
+ install -m 0644 ${WORKDIR}/tmpfiles ${D}${sysconfdir}/tmpfiles.d/${PN}.conf
+}
+
+pkg_postinst_${PN} () {
+ if [ -z "$D" ]; then
+ if type systemd-tmpfiles >/dev/null; then
+ systemd-tmpfiles --create
+ elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
+ ${sysconfdir}/init.d/populate-volatile.sh update
+ fi
+ fi
+}
+
+PACKAGES += "\
+ ${PN}-plugin-test \
+ ${PN}-plugin-test-dbg \
+ ${PN}-plugin-test-staticdev \
+ ${PN}-plugin-stonith2 \
+ ${PN}-plugin-stonith2-dbg \
+ ${PN}-plugin-stonith2-staticdev \
+ ${PN}-plugin-stonith2-ribcl \
+ ${PN}-plugin-stonith-external \
+ ${PN}-plugin-raexec \
+ ${PN}-plugin-raexec-dbg \
+ ${PN}-plugin-raexec-staticdev \
+ ${PN}-plugin-interfacemgr \
+ ${PN}-plugin-interfacemgr-dbg \
+ ${PN}-plugin-interfacemgr-staticdev \
+ ${PN}-plugin-compress \
+ ${PN}-plugin-compress-staticdev \
+ ${PN}-plugin-compress-dbg \
+ ${PN}-lrmtest \
+ "
+
+FILES_${PN} = " \
+ /etc/ /var ${libdir}/lib*.so.* \
+ /usr/sbin \
+ /usr/share/cluster-glue/*sh \
+ /usr/share/cluster-glue/*pl \
+ /lib64/heartbeat/plugins/InterfaceMgr/ \
+ ${libdir}/heartbeat/transient-test.sh \
+ ${libdir}/heartbeat/logtest \
+ ${libdir}/heartbeat/ipctransientserver \
+ ${libdir}/heartbeat/base64_md5_test \
+ ${libdir}/heartbeat/ipctest \
+ ${libdir}/heartbeat/ipctransientclient \
+ ${libdir}/heartbeat/ha_logd \
+ ${libdir}/heartbeat/lrmd \
+ "
+
+FILES_${PN}-dbg += "${libdir}/heartbeat/.debug/"
+
+FILES_${PN}-plugin-test = "${libdir}/heartbeat/plugins/test/test.so"
+FILES_${PN}-plugin-test-staticdev = "${libdir}/heartbeat/plugins/test/test.*a"
+FILES_${PN}-plugin-test-dbg = "${libdir}/heartbeat/plugins/test/.debug/"
+FILES_${PN}-plugin-stonith2 = " \
+ ${libdir}/stonith/plugins/xen0-ha-dom0-stonith-helper \
+ ${libdir}/stonith/plugins/stonith2/*.so \
+ "
+FILES_${PN}-plugin-stonith2-ribcl = "${libdir}/stonith/plugins/stonith2/ribcl.py"
+
+FILES_${PN}-plugin-stonith2-dbg = "${libdir}/stonith/plugins/stonith2/.debug/"
+FILES_${PN}-plugin-stonith2-staticdev = "${libdir}/stonith/plugins/stonith2/*.*a"
+
+FILES_${PN}-plugin-stonith-external = "${libdir}/stonith/plugins/external/"
+FILES_${PN}-plugin-raexec = "${libdir}/heartbeat/plugins/RAExec/*.so"
+FILES_${PN}-plugin-raexec-staticdev = "${libdir}/heartbeat/plugins/RAExec/*.*a"
+FILES_${PN}-plugin-raexec-dbg = "${libdir}/heartbeat/plugins/RAExec/.debug/"
+
+FILES_${PN}-plugin-interfacemgr = "${libdir}/heartbeat/plugins/InterfaceMgr/generic.so"
+FILES_${PN}-plugin-interfacemgr-staticdev = "${libdir}/heartbeat/plugins/InterfaceMgr/generic.*a"
+FILES_${PN}-plugin-interfacemgr-dbg = "${libdir}/heartbeat/plugins/InterfaceMgr/.debug/"
+
+FILES_${PN}-plugin-compress = "${libdir}/heartbeat/plugins/compress/*.so"
+FILES_${PN}-plugin-compress-staticdev = "${libdir}/heartbeat/plugins/compress/*.*a"
+FILES_${PN}-plugin-compress-dbg = "${libdir}/heartbeat/plugins/compress/.debug/"
+
+FILES_${PN}-lrmtest = "/usr/share/cluster-glue/lrmtest/"
+
+RDEPENDS_${PN} += "perl"
+RDEPENDS_${PN}-plugin-stonith2 += "bash"
+RDEPENDS_${PN}-plugin-stonith-external += "bash python perl"
+RDEPENDS_${PN}-plugin-stonith2-ribcl += "python"