summaryrefslogtreecommitdiff
path: root/recipes-support/cluster-resource-agents/cluster-resource-agents_3.9.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/cluster-resource-agents/cluster-resource-agents_3.9.6.bb')
-rwxr-xr-xrecipes-support/cluster-resource-agents/cluster-resource-agents_3.9.6.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/recipes-support/cluster-resource-agents/cluster-resource-agents_3.9.6.bb b/recipes-support/cluster-resource-agents/cluster-resource-agents_3.9.6.bb
new file mode 100755
index 0000000..1fdfedb
--- /dev/null
+++ b/recipes-support/cluster-resource-agents/cluster-resource-agents_3.9.6.bb
@@ -0,0 +1,81 @@
+DESCRIPTION = "OCF resource agents for use by compatible cluster managers"
+LICENSE = "GPLv2"
+DEPENDS = "cluster-glue"
+RDEPENDS_${PN} = "bash"
+
+SRC_URI = " \
+ https://github.com/ClusterLabs/resource-agents/archive/v${PV}.tar.gz \
+ file://remove-doc-generation.patch \
+"
+
+SRC_URI[md5sum] = "6873d5a217aee3026193fb85bfa18a4a"
+SRC_URI[sha256sum] = "39722cdee68ff96d06788f05f325bd21ec2fc59c59d847e5e4b23c6df23bf678"
+
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.GPLv2;md5=751419260aa954499f7abaabaa882bbe"
+
+inherit autotools-brokensep
+
+S = "${WORKDIR}/resource-agents-${PV}"
+
+PACKAGES =+ "ldirectord ldirectord-doc ocft"
+
+FILES_ldirectord = " \
+ ${sbindir}/ldirectord \
+ ${sysconfdir}/ha.d/resource.d/ldirectord \
+ ${sysconfdir}/init.d/ldirectord \
+ ${sysconfdir}/logrotate.d/ldirectord \
+ ${libdir}/ocf/resource.d/heartbeat/ldirectord \
+ "
+FILES_ldirectord-doc = "${mandir}/man8/ldirectord.8*"
+
+# Missing:
+# Authen::Radius
+# Net::LDAP
+# Net::IMAP::Simple::SSL
+# Net::IMAP::Simple
+
+#TODO: libmailtools-perl libsocket6-perl libwww-perl
+RDEPENDS_ldirectord += " \
+ libdbi-perl \
+ libnet-dns-perl \
+ perl \
+ perl-module-getopt-long \
+ perl-module-net-ftp \
+ perl-module-net-smtp \
+ perl-module-pod-usage \
+ perl-module-posix \
+ perl-module-socket \
+ perl-module-strict \
+ perl-module-sys-hostname \
+ perl-module-sys-syslog \
+ perl-module-vars \
+ "
+
+FILES_${PN} += " \
+ /lib/heartbeat/ \
+ /resource.d/heartbeat \
+ /resource.d/redhat \
+ /run/resource-agents \
+ /usr/share/cluster/ \
+ ${libdir}/heartbeat/findif \
+ ${libdir}/heartbeat/ocf-returncodes \
+ ${libdir}/heartbeat/ocf-shellfuncs \
+ ${libdir}/heartbeat/send_arp \
+ ${libdir}/heartbeat/sfex_daemon \
+ ${libdir}/heartbeat/tickle_tcp \
+ ${libdir}/ocf/resource.d/heartbeat/ \
+ ${datadir}/resource-agents/ra-api-1.dtd \
+ "
+
+FILES_ocft += " \
+ ${datadir}/resource-agents/ocft \
+ ${sbindir}/ocft \
+ "
+
+FILES_${PN}-dbg += "\
+ ${libdir}/heartbeat/.debug/ \
+ ${libdir}/ocf/resource.d/heartbeat/.debug/ \
+ ${libdir}/cluster-resource-agents/heartbeat/.debug/ \
+ /resource.d/heartbeat/.debug/ \
+"