summaryrefslogtreecommitdiff
path: root/recipes-support/mysql/files/fix-cmake-module-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/mysql/files/fix-cmake-module-path.patch')
-rwxr-xr-xrecipes-support/mysql/files/fix-cmake-module-path.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-support/mysql/files/fix-cmake-module-path.patch b/recipes-support/mysql/files/fix-cmake-module-path.patch
new file mode 100755
index 0000000..f4c7961
--- /dev/null
+++ b/recipes-support/mysql/files/fix-cmake-module-path.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt.org 2015-09-02 08:24:51.553482621 +0200
++++ b/CMakeLists.txt 2015-09-02 08:25:55.125811412 +0200
+@@ -40,8 +40,6 @@ MESSAGE(STATUS "Running cmake version ${
+ # Will set GIT_EXECUTABLE and GIT_FOUND
+ FIND_PACKAGE(Git)
+
+-SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
+-
+ # First, decide about build type (debug or release)
+ # If custom compiler flags are set or cmake is invoked with -DCMAKE_BUILD_TYPE,
+ # respect user wishes and do not (re)define CMAKE_BUILD_TYPE. If WITH_DEBUG{_FULL}
+@@ -110,6 +108,8 @@ ELSE()
+ ENDIF()
+ PROJECT(${MYSQL_PROJECT_NAME})
+
++SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
++
+ # Maintainer mode is default on only for Linux debug builds using GCC/G++
+ IF(CMAKE_BUILD_TYPE MATCHES "Debug" OR WITH_DEBUG)
+ IF(CMAKE_SYSTEM_NAME MATCHES "Linux" AND