summaryrefslogtreecommitdiff
path: root/drivers/staging/rtl8188eu/hal/phy.c
AgeCommit message (Collapse)Author
2016-09-23staging: r8188eu: remove RFType member of odm_dm_struct structureIvan Safonov
rf_type is always equal to ODM_1T1R. So, only RF PATH A exists for r8188eu device... Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-09-23staging: r8188eu: remove rf_type member of hal_data_8188e structureIvan Safonov
rf_type is always equal to RF_1T1R. Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-09-20staging: r8188eu: remove GET_HAL_DATA macroIvan Safonov
GET_HAL_DATA replaced by its definition. Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-09-12staging: r8188eu: rename phy_set_bw_mode to rtw_hal_set_bwmodeIvan Safonov
And remove two one-line wrappers. Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-09-12staging: r8188eu: rename phy_sw_chnl to rtw_hal_set_chanIvan Safonov
And remove two one-line wrappers. Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-09-12staging: r8188eu: rename phy_query_rf_reg to rtw_hal_read_rfregIvan Safonov
And remove two one-line wrappers. Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-09-12staging: r8188eu: remove bNotifyChannelChange member of struct adapterIvan Safonov
Default value of this variable used only to produce debug output. Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-03-28staging: rtl8188eu: Remove license paragraph with mailing addressKyle Kuffermann
This fixes the issue reported by checkpatch.pl: "Do not include the paragraph about writing to the Free Software Foundation's mailing address from the sample GPL notice. The FSF has changed addresses in the past, and may do so again. Linux already includes a copy of the GPL." in all files for the rtl8188eu driver. Signed-off-by: Kyle Kuffermann <kyle.kuffermann@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2016-02-20staging: rtl8188eu: Remove RF_PATH_C & RF_PATH_DAndrew Bradford
RTL8188EE has a maximum of 2 RF paths (chains) so paths C and D are not needed to support this part. Signed-off-by: Andrew Bradford <andrew@bradfordembedded.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-10-29staging: rtl8188eu: abs kernel macro used in simularity_compare functionIvan Safonov
abs macro is useful for determining the difference between the two integers. Signed-off-by: Ivan Safonov <insafonov@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-10-25rtl8188eu : BIT() macro cleanupAnish Bhatt
Use the BIT(x) macro directly instead using multiple BITX defines. Signed-off-by: Anish Bhatt <anish@gatech.edu> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-06-13staging: rtl8188eu: remove unused variablesSudip Mukherjee
These variables were being set but not used afterwards. Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-03-16Staging: rtl8188eu: Remove parentheses around right side an assignmentHaneen Mohammed
Parentheses are not needed around the right hand side of an assignment. This patch remove parenthese of such occurenses. Issue was detected and solved using the following coccinelle script: @rule1@ identifier x, y, z; expression E1, E2; @@ ( x = (y == z); | x = (E1 == E2); | x = -( ... -) ; ) Signed-off-by: Haneen Mohammed <hamohammed.sa@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-03-02Staging: rtl8188eu: Remove unused variableVatika Harlalka
Remove unused variable assignment for is2t and assign sim_bitmap at declaration to make the code more compact. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-03-02Staging: rtl8188eu: Move variable assignmentVatika Harlalka
Variable path_on is assigned explicitly in the if branch and so its assignment outside can be moved to the else branch. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Remove unnecessary codeVatika Harlalka
Code removed as variables assigned are not used anywhere. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Refactor conditional code to increase readabilityVatika Harlalka
Remove the nested conditionals. The if and else-if have the same code so they are combined to make the code more compact. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Combine two loops to increase readabilityVatika Harlalka
The first loop assigns values to ofdm_index array and the second checks for boundary conditions. They are combined and a comment is added to increase clarity. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Remove unnecessary if conditionVatika Harlalka
Remove this branch as is2t is defined false and is not modified. The variable value32 is then unused. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Remove unnecessary variableVatika Harlalka
Remove unnecessary variable and replace its uses with previously defined variable. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Refactored code to increase readilityVatika Harlalka
Refactored the conditional code to make it more compact. Replaced the ternary operators with abs() macro to increase readability. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Replace ternary operator with existing macroVatika Harlalka
Replace ternary operator with existing abs() macro to increase code readability. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Remove redundant if conditionVatika Harlalka
Remove redundant if condition as !result is always false. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Changed array and loop constructVatika Harlalka
This function only required the array from the 14th element onwards. Therefore, the array size is reduced and the loop counter is modified so as to start from 0. Also, the assignment of variable place is redundant as it is initialized again in the loop. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Replace unneeded switch-case blockVatika Harlalka
Replace switch-case block with single if statement to increase code readability. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2015-02-26Staging: rtl8188eu: Remove unnecessary variableVatika Harlalka
Remove unneccessary variable and replace its uses with another variable which is previously defined. Signed-off-by: Vatika Harlalka <vatikaharlalka@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2014-11-04staging: rtl8188eu: Fix coding style space related ERROR problemsJia He
This fixes space related ERROR reports by checkpatch.pl Generated by $ git ls-files "drivers/staging/rtl8188eu/*.[ch]" | \ xargs ./scripts/checkpatch.pl -f --fix-inplace --strict --types=SPACING Already checked by text comparasion $git diff -w and binary comparasion of r8188eu.ko $objdiff diff <old_commit> <new_commit> Signed-off-by: Jia He <hejianet@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2014-09-08staging: rtl8188eu: Remove HalPhyRf_8188e.cnavin patidar
Move functions from HalPhyRf_8188e.c to phy.c . Signed-off-by: navin patidar <navin.patidar@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2014-09-07staging: rtl8188eu: include missing headerNicolas Thery
This patch fixes the following sparse warnings: drivers/staging/rtl8188eu/hal/phy.c:46:5: warning: symbol 'phy_query_bb_reg' was not declared. Should it be static? drivers/staging/rtl8188eu/hal/phy.c:56:6: warning: symbol 'phy_set_bb_reg' was not declared. Should it be static? drivers/staging/rtl8188eu/hal/phy.c:129:5: warning: symbol 'phy_query_rf_reg' was not declared. Should it be static? drivers/staging/rtl8188eu/hal/phy.c:140:6: warning: symbol 'phy_set_rf_reg' was not declared. Should it be static? drivers/staging/rtl8188eu/hal/phy.c:228:6: warning: symbol 'phy_set_tx_power_level' was not declared. Should it be static? drivers/staging/rtl8188eu/hal/phy.c:324:6: warning: symbol 'phy_set_bw_mode' was not declared. Should it be static? drivers/staging/rtl8188eu/hal/phy.c:360:6: warning: symbol 'phy_sw_chnl' was not declared. Should it be static? Signed-off-by: Nicolas Thery <nthery@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2014-08-31staging: rtl8188eu: Rework function rtl8188e_PHY_RF6052SetOFDMTxPower()navin patidar
Rename CamelCase variables and function name. Signed-off-by: navin patidar <navin.patidar@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2014-08-31staging: rtl8188eu: Rework function rtl8188e_PHY_RF6052SetCckTxPower()navin patidar
Rename CamelCase variables and function name. Remove redundant variable TurboScanOff. Signed-off-by: navin patidar <navin.patidar@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2014-08-31staging: rtl8188eu: Rework function rtl8188e_PHY_RF6052SetBandwidth()navin patidar
Rename CamelCase variables and function name. Signed-off-by: navin patidar <navin.patidar@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
2014-08-31staging: rtl8188eu: Rename rtl8188e_phycfg.c to phy.cnavin patidar
Signed-off-by: navin patidar <navin.patidar@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>